RubyGemsのupdateの方法が変わっていた

せっかくMerb1.0がでたことだしインストールしてみようかと思ったら、gemを1.3以上いれやがれ!と怒られてしまった。それならアップデートするかーと思い、update –systemをやってsuccessと出たはいいけど、gem -vで1.2と表示される。MacPortsの方でアップデートして、1.3入れても-vは1.2でなんぞーとか思っていたらupdateの方法が変わってたみたい。

以下、update手順。

  1. RubyForgeからrubygems-upate-1.3.1.gemをダウンロード
  2. $ sudo gem install rubygems-update-1.3.1.gem
  3. update_rubygemsというコマンドができてるので実行。
    $ sudo update_rubygems
  4. 完了

これで無事、RubyGemsの1.3.1がインストールされた。

$ gem -v
1.3.1
$ sudo gem install merb
・・・
・・・
37 gems installed

これでOK。37gems installedってのも凄いな。